PHP is among the most commonly used server-side programming languages. It’s very popular since it’s free software, which can be used to create interactive websites such as community sites, online stores or e-teaching sites as opposed to static HTML-based sites. A PHP module must be available on the server where a PHP website is hosted so that its code can be ‘deciphered’. Because there are no license fees for this kind of module and the language offers limitless possibilities for the web-based apps that you develop, there are 100s of millions of PHP websites. In addition, there’re a lot of PHP-based scripts, which you can use for your sites without the need to have any coding knowledge. Since there’re a number of PHP versions, you need to check whether the very same version that you used whilst developing your site is installed on the web server as well.
PHP 4, PHP 5 and PHP 7 Support in Shared Hosting
With our shared packages, you’ll be able to pick which PHP version will be enabled for your shared hosting account, since multiple versions are supported on our servers. With as little as one click of the mouse, you’ll be able to switch between PHP 4, 5, 7 and anytime a new version is introduced in the future, we’ll include it in the Hepsia Control Panel without removing the older versions. Thus, you will be able to host all the websites that you have set up over the years. In contrast with many other web hosting vendors, we will not compel you to update such websites, as a script may be outdated, but this does not necessarily mean that it’s vulnerable as you may have implemented modifications to its code to plug safety breaches. For your convenience’s sake, you’ll even be able to specify a different version of PHP for each individual site that you host in your shared web hosting account.
PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting
We’re steadfast in our belief that years spent creating a website should not go down the tube, which goes to say that if you order a semi-dedicated server from our company, you will be able to run any script, regardless of whether it is new or old. In stark contrast with lots of hosting companies, we support several different versions of PHP on our advanced cloud hosting platform – 4, 5 and 7. Not only will you be able to enable the required version from your Hepsia Control Panel, but you’ll also have the opportunity to pick a different PHP version for each single website. The latter can be done merely by inserting an .htaccess file in the root folder of the given site. You can change the current version both for a single website and for the account itself and the update will be applied in less than a few minutes. With our hosting services, you can be certain that you won’t ever confront any website compatibility problems.